Github Pages 升级 Jekyll 版本造成博客构建失败

ZMonster at 
Github Pages 升级 Jekyll 版本造成博客构建失败的配图
点击邮件给出的链接,里面都是一些常规的排错建议,并没有给我相应的错误信息,看完还是一头雾水。为了确定是不是最近一次 commit 提交的文章内容有什么问题,我把 repo 回滚到了出错前的一个 commit 上,然后 'push -f' ,一秒钟之后又收到了相同的邮件。当时感觉有点懵,但是因为手头还有别的事情,于是就丢在那里不管了。直到昨天,我才给 Github 发了封邮件,说了一下我的情况。很快就收到了回复。原来是 Github Pages 将 Jekyll 升级到了 3.2.1 ,而在 Jekyll 3.2.1 中,配置文件 _config.yml 中的 "theme" 字段,现在被用作设……